Cocoapod 是一套3rd party plugins/framework 版本管理工具 for IOS .
透過設定擋的方式 統一管理你要使用的 plugins 以及版本
然後 install 就可以全部幫您解決 upgrade/downgrade 的問題 !

  1. 安裝
    • 先要安裝好 Ruby 在您的系統裡 (這部分請 Google "install ruby")
    • 打開 terminal , 'sudo gem install cocoapods' 安裝 cocoapods
    • 安裝完後先執行 pod setup 讓cocoapods setup master repo P.S. 如果遇到 pod package找不到的問題可以 pod repo remove master , 再 pod setup 重新設定 master repo
  2. 設定
    • 新開一個 xcode project
    • 打開 terminal , 'cd /go/to/xcode/Project/'
    • vi Podfile 新增編輯 Podfile (這邊以安裝 pop 為例)
    • 完成後 離開 vi , 輸入 'pod install' 完成!
    • open abc.xcworkspace 由 pod 更改過的新的 workspace
    • 接下來就可以開始使用 pod 安裝的 3rd plugins/frameworks 來寫code 勒~!